cấu hình Static routing - định tuyến tĩnh

By
Bài viết này mình xin hướng dẫn cấu hình Static route. Trước tiên mình xin giới thiệu sơ qua về lí thuyết Static Route.
1. Giới thiệu định tuyến tĩnh
Đối với định tuyến tĩnh các thông tin về đường đi phải do người quản trị mạng nhập cho router .Khi cấu trúc mạng có bất kỳ thay đổi nào thì chính người quản trị mạng phải xoá hoặc thêm các thông tin về đường đi cho router .Những loại đường đi như vậy gọi là đường đi cố định .Đối với hệ thống mạng lớn thì công việc bảo trì mạng định tuyến cho router như trên tốn rất nhiều thời gian .Còn đối với hệ thống mạng nhỏ ,ít có thay đổi thì công việc này đỡ mất công hơn .Chính vì định tuyến tĩnh đòi hỏi người quản trị mạng phải cấu hình mọi thông tin về đường đi cho router nên nó không có được tính linh hoạt như định tuyến động .Trong những hệ thống mạng lớn ,định tuyến tĩnh thường được sử dụng kết hợp với giao thức định tuyến động cho một số mục đích đặc biệt.
2. Hoạt động của định tuyến tĩnh
Hoạt động của định tuyến tĩnh có thể chia ra làm 3 bước như sau:
+ Đầu tiên ,người quản trị mạng cấu hình các đường cố định cho router
+ Router cài đặt các đường đi này vào bảng định tuyến
+ Gói dữ liệu được định tuyến theo các đường cố định này
Trong hình 1 và 2 là 2 câu lệnh mà người quản trị của router Hoboken cấu hình đường cố định cho router đến mạng 172.16.1.0/24 và 172.16.5.0/24 .Ở hình 1,câu lệnh này chỉ cho router biết đường đến mạng đích đi ra bằng cổng giao tiếp nào .Còn ở hình 2 ,câu lệnh này chỉ cho router biết địa chỉ IP của router kế tiếp là gì để đến được mạng đích .Cả 2 câu lệnh đều cài đặt đường cố định vào bảng định tuyến của router Hoboken. Điểm khác nhau duy nhất giữa 2 câu lệnh này là chỉ số tin cậy của 2 đường cố định tương ứng trên bảng định tuyến của router sẽ khác nhau.
Static routing, dinh tuyen tinh, câu lệnh cấu hình định tuyến tĩnh, Demo static route

Chỉ số tin cậy là một thông số đo lường độ tin cậy của một đường đi .Chỉ số này càng thấp thì độ tin cậy càng cao .Do đó ,nếu đến cùng một đích thì con đường nào có chỉ số tin cậy thấp hơn thì đường đó được vào bảng định tuyến của router trước. Trong ví dụ trên,đường cố định sử dụng địa chỉ IP của trạm kế tiếp sẽ có chỉ số tin cậy mặc định là 1,còn đường cố định sử dụng cổng ra thì có chỉ số tin cậy mặc định là 0 .Nếu bạn muốn chỉ định chỉ số tin cậy thay vì sử dụng giá trị mặc định thì bạn thêm thông số này vào sau thông số về cổng ra / địa chỉ IP trạm kế của câu lệnh .Giá trị của chỉ số này nằm trong khoảng từ 0 đến 255.
Waycross(config)# ip router 172.16.3.0 255.255.255.0 172.16.4.1.130
Nếu router không chuyển được gói ra cổng giao tiếp đã được cấu hình thì có nghĩa là cổng giao tiếp đang bị đóng, đường đi tương ứng cũng sẽ không được đặt vào bảng định tuyến .
3. Demo cấu hình định tuyến tĩnh
*+* Đinh tuyến tĩnh (static route)
Sơ đồ bài Demo mình xin trình bày như hình vẽ sau:
Mô hình định tuyến tĩnh, Demo static route
Mô hình triển khai
Để dễ hiểu mình cấu hình theo các bước sau:
3.1. Đặt IP cho các cổng interface
- Đối với Router A

Router>enable                                viết tắt là en
Router# config terminal                        viết tắt là conf t
Router(config)#hostname RA
RA(config)#interface f0/0                      viết tắt là int f0/0
RA(config-if)# ip address 10.1.1.1 255.0.0.0
RA(config-if)#exit
RA(config)#interface s0/0
RA(config-if)#ip address 172.16.1.1 255.255.0.0
RA(config-if)#no shutdown
RA(config-if)#exit

-Đối với RouterB
Router>en
Router# conf t
Router(config)#hostname RB
RB(config)#interface f0/0
RB(config-if)# ip address 192.168.1.1 255.255.255.0
RB(config-if)#exit
RB(config)#int s0/0
RB(config-if)#ip address 172.16.1.2 255.255.0.0
RB(config-if)#no shutdown
RB(config-if)#clock rate 64000
RB(config-if)#exit
RB(config)#int s0/1
RB(config-if)#ip address 11.1.1.1 255.0.0.0
RB(config-if)#no shutdown
RB(config-if)#clock rate 64000
RB(config-if)#exit


RouterB có 1 điểm lưu ý đó là " RouterB đóng vai trò nhà cung cấp mạng" nên sẽ có đặt xung nhịp clock rate 64000 ( clock rate để đảm bảo tốc độ xung nhịp cho truyền dữ liệu. Tốc độ xung nhịp này do DCE cấp )
-Đối với RouterC
Router>en
Router# conf t
Router(config)#hostname RC
RC(config)#int f0/0
RC(config-if)# ip address 173.16.1.1 255.255.0.0
RC(config-if)#exit
RC(config)#int s0/0
RC(config-if)#ip address 11.1.1.2 255.0.0.0
RC(config-if)#no shutdown
RC(config-if)#exit


Xong bước cấu hình địa chỉ IP cho các interface.
3.2. Cấu hình đường đi cho route (static route)
Các bạn thấy ở con RouterA có 3 lớp mạng mà nó chưa đi đến được đó là ( next hop )
11.0.0.0
192.168.1.0
173.16.0.0
Như vậy các bạn sẽ phải chỉ đường đi cho RA tới được 3 mạng đó

RA(config)# ip route 11.0.0.0 255.0.0.0 172.16.1.2
RA(config)# ip route 192.168.1.0 255.255.255.0 172.16.1.2
RA(config)# ip route 173.16.0.0 255.255.0.0 172.16.1.2

Tương tự RouterB có 2 lóp mạng mà nó chưa đi đến được đó là ( next hop )
10.0.0.0
173.16.0.0
RB(config)# ip route 10.0.0.0 255.0.0.0 172.16.1.1
RB(config)# ip route 173.16.0.0 255.255.0.0 11.1.1.2

RouterC tương tự RouterA. Có 3 lớp mạng trong mô hình mà nó chưa hiểu (next hop )
172.16.0.0
192.168.1.0
10.0.0.0
RC(config)# ip route 172.16.0.0 255.255.0.0 11.1.1.1
RC(config)# ip route 192.168.1.0 255.255.255.0 11.1.1.1
RC(config)# ip route 10.0.0.0 255.0.0.0 11.1.1.1

Để xem địa chỉ IP các cổng của router và bước đi của nó các bạn dùng lệnh
show ip route
*+* Định tuyến tĩnh mặc định (static default route)
   Với dạng mặc định như thế này thì đơn giản hơn rất nhiều. Các bạn chi cần route cho lớp mạng bạn cần đi đến mặc định là 0.0.0.0 0.0.0.0. Ví dụ trong trường hợp này mình sẽ route như sau:
Trên RA
RA(config)# ip route 0.0.0.0 0.0.0.0 172.16.1.2

Trên RB đóng vai trò là Router nhà cung cấp nên ta không để mặc định

Trên RC
RC(config)# ip route 0.0.0.0 0.0.0.0 11.1.1.1

Đối với các HostA, HostB, HostC khi các bạn đặt địa chỉ IP các bạn trỏ Defalt Gateway về cổng F0/0 của con router đó
Bài viết mình chưa trình bày tới hạn chế của static route

Chúc các bạn học tập tốt !!!
Chuyên mục: ,

12 comments:

  1. bài viết rất hay xin cảm ơn!

    ReplyDelete
  2. chào bạn mình đã làm giống như bạn mà các dây serial vẫn k hiện màu xanh báo đã kết nối,bạn cho mình lời khuyên với

    ReplyDelete
  3. Có thể bạn chưa bật cổng Serial lên. Bạn dùng Cisco Packet Tracer tthif có thể bật lên bằng giao diện, hoặc có thể dùng lệnh.
    Router(config)#interface serial S0/0/0
    Router(config-if)#no shutdown
    Ở Lab cấu hình trên mình có trình bày câu lệnh này, bạn coi lại cổng đã gán đúng chưa.

    ReplyDelete
  4. mình đã làm giống y như bạn.tại sao 3 con route không thể thông tới nhau vậy bạn?bạn xem kĩ lại hộ mình bài viết của bạn xem có lỗi 1 chỗ nào không nhé...hoặc làm ơn liên hệ nick yahoo để hướng dẫn lại cho mình nhé : me_anh_ket_em_roi_day
    thanks!!!

    ReplyDelete
  5. Bạn chú ý cổng nối serial cho các router. Mình cũng đã trình bày RouterB đóng vai trò là Router nhà cung cấp mạng nên bạn sẽ chọn cổng xung nhịp là DCE.
    Bài viết mình đã làm trên đúng, mình làm trên 2 phần mềm : Cisco packet và CCNA network visualizer đều ổn định.
    Bạn đọc kỹ lý thuyết của định tuyến tĩnh nhé !

    ReplyDelete
  6. ko dinh tuyen duoc.ban route erro

    ReplyDelete
    Replies
    1. Bạn làm sai hay bài viết sai vậy ?

      Delete